搜索
❏ 站外平台:

让你的 Linux 终端变得酷炫复古

作者: 译者: LCTT Xingyu.Wang

| 2020-07-19 21:41   评论: 1 收藏: 1    

怀旧?那就复古终端应用程序  吧 —— 顾名思义,它既酷又复古。

你还记得那个到处都是 CRT 显示器,终端屏幕经常闪烁的年代吗?你不需要那么老,就能见证它的存在。如果你看上世纪九十年代初的电影,你会看到大量的 CRT 显示器和绿色/黑白的letou游戏提示符。那种极客的光环,让它感觉很酷。

如果你厌倦了你的仿真终端的外观,你需要一些酷炫的“新”东西, 会给你一个复古的终端机外观,让你重温过去。你还可以改变它的颜色、动画种类,并为它添加一些效果。

Linux 中用 Snap 包

在 Linux 中 cool-retro-term 的方法有很多种。一种与发行版无关的方法是使用 Snap 软件包。如果你的 Linux 发行版支持 Snap,你可以使用这个letou游戏来 cool-retro-term

sudo snap install cool-retro-term --classic

Ubuntu 用户也可以在软件中心找到它。

如果你不想使用 Snap 包,也不用担心。还有其他的方法来它。

在基于 Ubuntu 的 Linux 发行版中

有一些 PPA 可以轻松地将 cool-retro-term 到基于 Ubuntu 的发行版上,如 Linux Mint、Elementary OS、Linux Lite 等。

对于 Ubuntu 18.04、18.10、19.04、Linux Mint 19 及更高版本,请使用此 PPA:

sudo add-apt-repository ppa:vantuz/cool-retro-term
sudo apt update
sudo apt install cool-retro-term

对于 Ubuntu 16.04 和 Linux Mint 18 系列,请用此 PPA:

sudo add-apt-repository ppa:noobslab/apps
sudo apt update
sudo apt-get install cool-retro-term

在基于 Arch 的 Linux 发行版中

在基于 Arch 的 Linux 发行版(如 Antergos 和 Manjaro)中 cool-retro-term,使用以下letou游戏:

sudo pacman -S cool-retro-term

从源码中

如果要这个应用程序,你需要先。在基于 Ubuntu 的发行版中,一些已知的依赖关系是:

sudo apt-get install git build-essential qmlscene qt5-qmake qt5-default qtdeclarative5-dev qtdeclarative5-controls-plugin qtdeclarative5-qtquick2-plugin libqt5qml-graphicaleffects qtdeclarative5-dialogs-plugin qtdeclarative5-localstorage-plugin qtdeclarative5-window-plugin 

其他发行版的已知依赖关系可以在 上找到。

现在使用下面的letou游戏来编译程序:

git clone https://github.com/Swordfish90/cool-retro-term.git
cd cool-retro-term
qmake && make

程序编译完成后,你可以用这个letou游戏来运行它:

./cool-retro-term

如果你喜欢把这个应用放在程序菜单中,以便快速访问,而不用每次都用letou游戏手动运行它,你可以使用下面的letou游戏:

sudo cp cool-retro-term.desktop /usr/share/applications

你可以在这里学习更多的终端技巧。享受 Linux 中的复古终端 :)


via: 

作者: 译者: 校对:

本文由  原创编译,Linux中国 荣誉推出



最新评论

来自上海的 Chrome 84.0|Mac 10.15 用户 2020-07-20 16:12 7 回复
macOS上了一个,不能输入大写。
LCTT 译者
Xingyu.Wang 💎💎
共计翻译: 529.0 篇 | 共计贡献: 2191
贡献时间:2014-07-25 -> 2020-07-23
访问我的 LCTT 主页 |


返回顶部

分享到微信

打开微信,点击顶部的“╋”,
使用“扫一扫”将网页分享至微信。